Author Topic: Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)  (Read 7298 times)

0 Members and 1 Guest are viewing this topic.

Offline chapas

  • Новичек
  • *
  • Posts: 4
  • Karma: 0
Hi there,
I'm still having a problem on ruTorrent UI

Bad response from server: (500 [error,getplugins]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

I have tried a lot of configurations with:
/home/root/.rtorrent.rc
/etc/lighttpd.conf
/www/pages/rutorrent/conf/config.php

On /www/logs/lighttpd.error.log i can read:

2012-01-09 23:22:10: (mod_fastcgi.c.3703) handling it in mod_fastcgi
2012-01-09 23:22:18: (mod_fastcgi.c.256cool unexpected end-of-file (perhaps the fastcgi process died): pid: 784 socket: unix:/tmp/php-fastcgi.socket-3
2012-01-09 23:22:18: (mod_fastcgi.c.3356) response not received, request sent: 1131 on socket: unix:/tmp/php-fastcgi.socket-3 for /rutorrent/php/getplugins.php?, closing connection

That is the only error i can find.

Can someone help on this issue?

Thanks,
chapas

Offline dillinger

  • Администратор
  • *
  • Posts: 1629
  • Karma: 1081
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #1 on: January 10, 2012, 03:44:07 PM »
Hi!

Are you installed all lighttpd modules from this a rtorrent pack? And please attach here your lighttpd.conf file.
0,9m - 5E+13E+19Е+4W

Offline chapas

  • Новичек
  • *
  • Posts: 4
  • Karma: 0
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #2 on: January 11, 2012, 11:42:02 AM »
Hi,
thanks for your answer.

I picked the package on your link and reinstall it again, here is the log:

http://dl.dropbox.com/u/39202357/install_log.TXT

One good new, the error has changed:

[11.01.2012 09:36:50] WebUI started.
[11.01.2012 09:37:08] rTorrent's user can't access 'id' program. Some functionality will be unavailable.
[11.01.2012 09:37:08] rTorrent's user can't access 'stat' program. Some functionality will be unavailable.
[11.01.2012 09:37:08] Bad response from server: (500 [error,list]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

These are my config files ATM:
http://dl.dropbox.com/u/39202357/.rtorrent.rc
http://dl.dropbox.com/u/39202357/config.php
http://dl.dropbox.com/u/39202357/lighttpd.conf

Ill try and check this new error.

Chapas

Offline dillinger

  • Администратор
  • *
  • Posts: 1629
  • Karma: 1081
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #3 on: January 11, 2012, 04:38:04 PM »
Quote
Collected errors:
 * Package screen md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
 * Cannot find package rtorrent.
 * Package screen md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
 * Cannot find package screen.

Install these packages manually. Before installation remove all entries with "rtorrent" and "screen" records from the file /usr/lib/opkg/status. For example:

Quote
Package: screen
Version: 4.0.3-r1
Depends: libc6 (>= 2.10), ncurses (>= 5.4)
Provides:
Status: install user installed
Architecture: mipsel
Installed-Time: 1319113600

Quote
Package: rtorrent
Version: 0.8.9-r2
Depends: ncurses (>= 5.4), libcurl4 (>= 7.19.7), libc6 (>= 2.10), libgnutls26 (>= 2.4.2), libgcrypt11 (>= 1.4.4), libgpg-error0 (>= 1.4), libtorrent14 (>= 0.12.9), libcrypto0.9.8 (>= 0.9.8j), libsigc-2.0-0 (>= 2.2.2), libstdc++6 (>= 4.4.3), libgcc1 (>= 4.4.3), xmlrpc-c (>= 1.24.03), libxml2 (>= 2.7.3), libz1 (>= 1.2.3)
Provides:
Status: install user installed
Architecture: mipsel
Installed-Time: 1319111316

0,9m - 5E+13E+19Е+4W

Offline chapas

  • Новичек
  • *
  • Posts: 4
  • Karma: 0
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #4 on: January 14, 2012, 05:01:53 AM »
Hi,
once again thanks for the help until now; just finished a fresh reinstall on my DM800 for Gemini iCVS image, after all updated..... No luck!

[14.01.2012 02:54:59] WebUI started.
[14.01.2012 02:55:00] Bad response from server: (500 [error,getplugins]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

This are my new files:

http://dl.dropbox.com/u/39202357/.rtorrent.rc
http://dl.dropbox.com/u/39202357/config.php
http://dl.dropbox.com/u/39202357/fresh_install_log.txt
http://dl.dropbox.com/u/39202357/lighttpd.conf
http://dl.dropbox.com/u/39202357/lighttpd.error.log

Thanks,
Chapas

Offline dillinger

  • Администратор
  • *
  • Posts: 1629
  • Karma: 1081
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #5 on: January 14, 2012, 11:33:33 AM »
I don't know. I don't have any problems with rtorrent. It works after installation without editing configuration files.


Quote
OpenDreambox 1.6.0 dm8000

dm8000 login: root
root@dm8000:~# /etc/init.d/rtorrentd start
Starting rtorrent 0.8.6 !!!
To use your rtorrent session, reattach screen using following command 'screen -r
'
Open your browser at http://192.168.1.4
192.168.1.4:8081/rutorrent
root@dm8000:~# netstat -an | grep 5000
tcp        0      0 127.0.0.1:5000          0.0.0.0:*               LISTEN
tcp        0      0 127.0.0.1:5000          127.0.0.1:4147          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4146          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4145          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4144          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4151          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4150          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4149          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4148          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4139          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4155          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4138          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4154          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4153          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4152          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4143          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4142          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4141          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4157          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4140          TIME_WAIT
tcp        0      0 127.0.0.1:5000          127.0.0.1:4156          TIME_WAIT
root@dm8000:~#
0,9m - 5E+13E+19Е+4W

Offline cdance

  • Новичек
  • *
  • Posts: 2
  • Karma: 0
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #6 on: January 20, 2012, 10:02:45 AM »
hi there..
i use on my dreambox dm8000 with the new NDE 3.0 img the rtorrent 0.8.9 and i get the same message

[20.01.2012 09:41:25] Bad response from server: (500 [error,getpeers]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

this message apear after the torrent download is complete and it seems that rtorrent it stop working

this are  a part of the running processess and tere is no rtorrent running

1063 root      100m S    /usr/bin/enigma2
1066 root      100m S    /usr/bin/enigma2
1100 root      100m S    /usr/bin/enigma2
1116 root      100m S N  /usr/bin/enigma2
1132 root      2084 S    /usr/lib/enigma2/python/Plugins/Extensions/AirPlayer/
9473 root      3236 S    SCREEN -dm -S rtorrent
9477 root      3156 S    /bin/sh
0923 root      3156 S    telnetd
0924 root      3156 S    -sh
1766 root      2840 S    top -n 3 -d 1
1767 root      3156 R    ps
oot@dm8000:~#

then i give the comand  /etc/init.d/rtorrentd start  but is not starting

btw i cannot find the rtorrent.rc in my /home/root/

and if i set the max dl perr from 100 to 15 for example allways i heave only 6 if i leave the 100 then my network crash even if i made 512 swap partition on my hdd

sorry for my bad english,
and i wish u all the best , nice job are u doing here

Offline chapas

  • Новичек
  • *
  • Posts: 4
  • Karma: 0
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #7 on: February 27, 2012, 04:06:30 AM »
Same on 0.9.0
:(
[27.02.2012 02:01:52] WebUI started.
[27.02.2012 02:01:56] Bad response from server: (500 [error,getplugins]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

Offline vladimir.cdi

  • Новичек
  • *
  • Posts: 2
  • Karma: 0
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #8 on: April 15, 2012, 11:35:30 PM »
Уважаемый dillinger,
мы как поклонники вашего таланта очень просим помощи с ликвидацией проблем с установкой вашей сборки rtorrent 0.8.9 на Gemini 5.0 (OE1.6). Проблема та же что и предыдущих ждунов, инсталлируется все без замечаний, rtorrent в списке задач висит,  но через веб интерфейс нет соединения с сервером. Подскажите какие логи смотреть где искать.

клиент очень нравится и привыкли уже к нему, но сидеть на 4.4 где работает 0,8,5 уже сил нет.
Сами с руками - но просто подскажите алгоритм поиска проблемы - мы уж сами покопаемся.

[15.04.2012 23:33:05] WebUI started.
[15.04.2012 23:33:05] Bad response from server: (500 [error,getplugins]) <?xml version="1.0" encoding="iso-8859-1"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"> <head> <title>500 - Internal Server Error</title> </head> <body> <h1>500 - Internal Server Error</h1> </body> </html>

1. rtorrent работает и качает (смотрел в терминале)
2. все файлы конфигурации lighttpd, rutorrent перепроверил по 5 раз
3. инструкции по настройке на http://code.google.com перечитываю уже по 10му разу

нам не к спеху, но хоть процедуру проверки работоспособности компонентов подскажите

после включения логов lighttpd получил вот такое:
2012-04-16 10:17:43: (mod_fastcgi.c.2568) unexpected end-of-file (perhaps the fastcgi process died): pid: 29027 socket: unix:/tmp/php-fastcgi.socket-3
2012-04-16 10:17:43: (mod_fastcgi.c.3356) response not received, request sent: 1069 on socket: unix:/tmp/php-fastcgi.socket-3 for /rutorrent/php/getplugins.php?, closing connection
« Last Edit: April 16, 2012, 11:20:14 AM by vladimir.cdi »

Offline dillinger

  • Администратор
  • *
  • Posts: 1629
  • Karma: 1081
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #9 on: April 16, 2012, 12:32:58 PM »
Я его ставил на оригинальный имидж от DMM. Стартует и работает без всяких дополнительных настроек. Есть правда баг, когда закачка доходит до конца и начинается сидирование, rtorrent "падает". То же самое происходит при повторном запуске. Хеширование загруженных файлов и опять падение. Если успел остановить, то продолжает работать как ни в чем не бывало. Почему так происходит непонятно и исправить не получается. Возможно баги gcc, возможно еще что то. Почему не работает rutorrent веб-интерфейс на Gemini 5.0 я не знаю. Попробуйте что нибудь посвежее. Вывод один, на 1.6 нормально торрент клиенты работать не будут. Еще одна проблема на уровне ядра (Falling back to dynamic skb allocation), когда "отваливается" сеть. Но тут хоть частично лечится созданием swap. Я бы рад помочь, но вряд ли смогу. Просить сделать какие либо исправления Dream Multimedia, это все равно, что писать письма "дедушке на деревню", как делал чеховский Ванька. Единственная надежда, что разродяться со временем на новое ядро, т.к конкуренты уже на версии 3.Х.Х и "отжали" уже немалую часть рынка.
0,9m - 5E+13E+19Е+4W

Offline vladimir.cdi

  • Новичек
  • *
  • Posts: 2
  • Karma: 0
Problem on rtorrent 0.8.9 (Stable Release) + rutorrent WebUI 3.3 (OE 1.6)
« Reply #10 on: April 19, 2012, 10:56:45 PM »
Я бы рад помочь, но вряд ли смогу.
А подскажите тогда, на чем собирали rtorrent 0.8.9 и xmlrpc-c? Что то у меня в OpenDreambox devshell ни то не другое не собирается.